MACD风洞,老鸭头,金蜘蛛形态选股源码

老鸭头选股公式。

MA5 := MA(CLOSE,5);
MA10 := MA(CLOSE,10);
MA60 := MA(CLOSE,60);
PDAY1 := BARSLAST(CROSS(MA5,MA60));
PDAY2 := BARSLAST(CROSS(MA10,MA60));
PDAY3 := BARSLAST(HIGH=HHV(HIGH,PDAY2));
PDAY4 := BARSLAST(CROSS(MA10,MA5));
PDAY5 := BARSLAST(CROSS(MA5,MA10));
A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND
PDAY5<5;
A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;
A3:=MA5>MA60 AND MA10>MA60 AND C>MA5;
A1 AND A2 AND A3;

 

金蜘蛛公式源码:

主图:

MA2:=EMA(C,2);

MA5:EMA(C,5);

MA13:EMA(C,13);

MA34:EMA(C,34);

MA55:EMA(C,55);

YCX:=MA5>=REF(MA5,1);

H1:=MAX(MAX(MA5,MA13),MA34);

L1:=MIN(MIN(MA5,MA13),MA34);

一阳穿三线:= H1<C AND O<L1 AND YCX AND MA2>REF(MA2,1);

STICKLINE(一阳穿三线,O,C,2,0),COLORYELLOW;

DRAWTEXT(一阳穿三线,L-0.1, '金蜘蛛'),COLORGREEN;

选股:

MA2:=EMA(C,2);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
MA34:=EMA(C,34);
MA55:=EMA(C,55);
YCX:=MA5>=REF(MA5,1);
H1:=MAX(MAX(MA5,MA13),MA34);
L1:=MIN(MIN(MA5,MA13),MA34);
VV:=H1<C AND O<L1 AND YCX AND MA2>REF(MA2,1);
金蜘蛛选股:IF(VV,1,0);

 

MACD风洞选股指标公式

dif:=macd.dif;
dea:=macd.dea;
a1:=barslast(cross(dea,dif));
a2:=cross(dif,dea);
xg:a1<6 and a2 and dif>=0 ;

 

 

 

 

更多优质秘籍,请加主编个人微信ugouku探讨,同时欢迎分享转发。
微信打赏微信打赏

为众人抱薪者,不可使其冻毙于风雪!求各位看官打赏,打赏后加站长好友(微信caileap),共同探索

最后编辑于:2020/5/10作者:闽发论坛

头像

该用户很懒,还没有介绍自己。