均线粘合选股公式大全

可根据下列公式自己增减线的数目,选股的时候也可用选股周期用周线

选股公式条件
1、四线粘合;
2、低位二次金叉;
3、然后一阳穿四线,同时放量(或者第二天补量);

{四线粘合}成功率39--37,还可以吧

V0:=EMA(C,5);
V1:=EMA(C,10);
V2:=EMA(C,15);
V3:=EMA(C,30);
V4:=EMA(C,60);
M1:=1000*V1/V4<=1015 AND 1000*V1/V4>=975;
M2:=1000*V2/V4<=1020 AND 1000*V2/V4>=980;
M3:=1000*V3/V4<=1015 AND 1000*V3/V4>=985;
M4:=M1 AND M2 AND M3 AND CROSS(V0,V1);
M5:=M1 AND M2 AND M3 AND CROSS(V0,V3);
M4 OR M5;

 

三线粘合金叉:
A5:=MA(C,5);
A10:=MA(C,10);
A30:=MA(C,30);
AA:=CROSS(A5,A10);
BB:=CROSS(A5,A30);
CC:=CROSS(A10,A30);
COUNT(AA,3)=1 AND COUNT(BB,3)=1 AND COUNT(CC,3)=1;

 

三线粘合向上加成交量:36--9。6
a5:=ma(c,5);
a10:=ma(c,10);
a30:=ma(c,30);
均线粘合:=count(max(max(a5,a10),a30)/min(min(a5,a10),a30)<1.03,5)>=3;
向上突破:=a5>ref(a5,1)and a10>ref(a10,1)and a30>ref(a30,1)and c>a5 and c>a30;
成交量突破:=v/ma(v,5)>2 and ma(v,5)>ma(v,10);
均线粘合 and 向上突破 and 成交量突破;

多条均线粘合:成功率--35--15
a13:=ma(c,13);
a21:=ma(c,21);
a34:=ma(c,34);
a55:=ma(c,55);
a120:=ma(c,120);
a240:=ma(c,240);
max(max(max(a13,a21),max(a34,a55)),max(a120,a240))/min(min(min(a13,a21),min(a34,a55)),min(a120,a240))<1.1 and a13>ref(a13,1)and a120>ref(a120,1);

三线粘合:
AA:=MA(C,5);
BB:=MA(C,10);
DD:=MA(C,30);
A1:=ABS((AA-C)/C);
A2:=ABS((BB-C)/C);
A3:=ABS((DD-C)/C);
B:=A1<0.05 AND A2<0.05 AND A3<0.05;
FILTER(B,10)=1 ;

通达信均线粘合选股公式

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,60);
MA5:=MA(CLOSE,120);
MA6:=MA(CLOSE,250);
A:MAX(MAX(MA1,MA2),MA3),LINETHICK0;
B:MIN(MIN(MA1,MA2),MA3),LINETHICK0;
三线粘合:IF(RANGE(100*(A-B)/B,0,5),100*(A-B)/B,DRAWNULL),LINETHICK0;
SA:MAX(MAX(MA1,MA2),MAX(MA3,MA4)),LINETHICK0;
SB:MIN(MIN(MA1,MA2),MIN(MA3,MA4)),LINETHICK0;

参数可以自行设置:D为均线多头排列天数,N1,N2,N3为涨幅限制,可根据自己需要设置!再结合其他指标组合选股!不足之处请高手指点!D为均线多头排列天数,设为2-3天都可,N1,N2,N3为涨幅限制,我一般设为1.5或是2(这个可根据自己要求设),具体如下:
参数名  缺省  最小  最大  步长
D     1    1   20    1
N1    1    1   20    0.5
N2    1    1   20    0.5
N3    1    1   20    0.5

源码:
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
A1:=MA5>MA10 AND MA10>MA20 AND MA20>MA30 AND ALL((MA5>MA10 AND MA10>MA20 AND MA20>MA30),D);
A2:=((MA5-MA10)/MA5)*100
A3:=A1 AND A2;
FILTER(A3,5);

三线合一  时间持续一日即可 当天盘后选至于相距多少算粘合我不知道怎么表达 下面是个均线三线粘合的选股公式 这样的粘合就行了
X1:=ABS(MA(C,10)/MA(C,20)-1)<0.01;
X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;
X3:=ABS(MA(C,5)/MA(C,20)-1)<0.01;
MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3;

MA6,18,25,45)均线粘合选股

A1:=MA(C,6);
A2:=MA(C,18);
A3:=MA(C,25);
A4:=MA(C,45);
AA:=(A1+A2+A3+A4)/4;
UP:=AA*(N/100)+AA;
DN:=AA-AA*(N/100);
COUNT(BETWEEN(A1,UP,DN) AND BETWEEN(A2,UP,DN) AND
BETWEEN(A3,UP,DN) AND BETWEEN(A4,UP,DN),M)=M;

CLOSE>A1 AND CLOSE>A2 AND CLOSE>A3 AND CLOSE>A4;

求高手给编写通达信版的均线粘合选股公式 :长短期均线要充分粘合要超过2个月以上 如果能加上MACD买点配合就更棒了

也可叫做长期横盘向上突破选股公式

 

给你一个,30日的够了,两个月太长了,源码下面网址里有图片演示.
通达信突破30日均线选股公式
TJ1:=(C-REF(C,1))/REF(C,1)*100>=0.1;
VAR1:=LLV(LOW,13);
VAR2:=HHV(HIGH,13);
VAR3:=SMA((CLOSE-VAR1)/(VAR2-VAR1)*100,5,1);
VAR4:=SMA((VAR2-CLOSE)/(VAR2-VAR1)*100,5,1);
AA:=VAR3;
BB:=VAR4;
VAR5:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
CC:=EMA(VAR5,3);
DD:=MA(C,30)>=REF(MA(C,30),1);
EE:= L<=MA(C,26) AND H>=MA(C,30) ;
MTM:=CLOSE-REF(CLOSE,15);
MAMTM:=MA(MTM,8);
FF:=MAMTM>REF(MAMTM,2);
XG: CC>=REF(CC,2)AND C>O AND TJ1 AND EE AND DD AND FF; 

要求:5日均线和10均线5天持续粘合,并且今日5日均线上行

A1:=ABS(MA(C,5)/MA(C,10)-1)<0.01;
A2:=ABS(REF(MA(C,5),1)/REF(MA(C,10),1)-1)<0.01;
A3:=ABS(REF(MA(C,5),2)/REF(MA(C,10),2)-1)<0.01;
A4:=ABS(REF(MA(C,5),3)/REF(MA(C,10),1)-3)<0.01;
A5:=ABS(REF(MA(C,5),4)/REF(MA(C,10),1)-4)<0.01;
MA(C,5)>REF(MA(C,5),1) AND A1 AND A2 AND A3 AND A4 AND A5;
正如2楼所说,5日和10日均线连续5天粘合几乎是不可能的。我帮你改为:5、10、20日3条均线粘合(1天),且5日均线上行。如果要加入60日均线那么根据下面的公式照葫芦画瓢,就可以了。
改进后的公式:
设置参数N:最小值0.01,最大值0.05,默认:0.02
A1:=ABS(MA(C,10)/MA(C,20)-1)REF(MA(C,5),1) AND A1 AND A2 AND A3;
通达信测试通过。

 

编写(1)5日、10日、60日均量线粘合;
(2)5日、10日均价线粘合;
(3)MACD的DIF和DEA也粘合;
同时满足以上三种条件的均线粘合选股公式,要通达信能用的

A1:=MAX(MAX(MA(V,5),MA(V,10)),MA(V,60))/MIN(MIN(MA(V,5),MA(V,10)),MA(V,60))<=1.4;
A2:=MAX(MA(C,5),MA(C,10))/MIN(MA(C,5),MA(C,10))<=1.4;
DIFF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIFF,9);
XG:A1 AND A2 AND CROSS(DIFF,DEA);

 

 

 

均线粘合选+均线多头排列选股公式

 

5,10,20日三线粘合

X1:=ABS(MA(C,10)/MA(C,20)-1)<0.01;{取1%振幅内粘合}

X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;

X3:=ABS(MA(C,5)/MA(C,20)-1)<0.01;

 

AA:=MA(C,5)>REF(MA(C,5),1);BB:=MA(C,10)>REF(MA(C,10),1);CC:=MA(C,5)>MA(C,10);{均线勾头向上}

 

CDJZ:=ABS(MA(C,20)-MA(C,120))/MA(C,120)<0.4;{长短均线距离绝对值越小越好}

 

MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3

AND CDJZ AND AA AND BB AND CC;

5,10,30日三线粘合

X1:=ABS(MA(C,10)/MA(C,30)-1)<0.01;{取1%振幅内粘合}

X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;

X3:=ABS(MA(C,5)/MA(C,30)-1)<0.01;

 

AA:=MA(C,5)>REF(MA(C,5),1);BB:=MA(C,10)>REF(MA(C,10),1);CC:=MA(C,5)>MA(C,10);{均线勾头向上}

 

CDJZ:=ABS(MA(C,30)-MA(C,120))/MA(C,120)<0.4;{长短均线距离绝对值越小越好}

 

MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3

AND CDJZ AND AA AND BB AND CC;

5,10,20,30日四线粘合

X1:=ABS(MA(C,10)/MA(C,20)-1)<0.01;{取1%振幅内粘合}

X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;

X3:=ABS(MA(C,5)/MA(C,20)-1)<0.01;

X4:=ABS(MA(C,5)/MA(C,30)-1)<0.01;

AA:=MA(C,5)>REF(MA(C,5),1);BB:=MA(C,10)>REF(MA(C,10),1);CC:=MA(C,5)>MA(C,10);{均线勾头向上}

CDJZ:=ABS(MA(C,20)-MA(C,120))/MA(C,120)<0.4;{长短均线距离绝对值越小越好}

MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3 AND X4

AND CDJZ AND AA AND BB AND CC;

 

5,10,20,60日四线粘合

X1:=ABS(MA(C,10)/MA(C,20)-1)<0.01;{取1%振幅内粘合}

X2:=ABS(MA(C,5)/MA(C,10)-1)<0.01;

X3:=ABS(MA(C,5)/MA(C,20)-1)<0.01;

X4:=ABS(MA(C,5)/MA(C,60)-1)<0.01;

AA:=MA(C,5)>REF(MA(C,5),1);BB:=MA(C,10)>REF(MA(C,10),1);CC:=MA(C,5)>MA(C,10);{均线勾头向上}

MA(C,5)>REF(MA(C,5),1) AND X1 AND X2 AND X3 AND X4

AND AA AND BB AND CC;

30,60,120日三线多排

A1:=MA(CLOSE,N);

A2:=MA(CLOSE,N1);

A3:=MA(CLOSE,N2);

CLOSE>A1 AND A1>A2 AND A2>A3  AND CLOSE>OPEN; 

 均线粘合选股公式
2010-12-31 23:12
转载自 cpx0614
最终编辑 kang56356
EMA8:=EMA(C,8);
EMA13:=EMA(C,13),COLORFFCCCC;
EMA21:=EMA(C,21),COLORFF00FF;
EMA34:=EMA(C,34),COLORYELLOW;
EMA55:=EMA(C,55),COLORFFCC66;
EMA89:=EMA(C,89),COLORBLUE;
F1:=EMA13-EMA21<130/1000 AND EMA13-EMA34<230/1000 AND EMA13-EMA55<330/1000;
F2:=EMA21-EMA13<130/1000 AND EMA21-EMA34<230/1000 AND EMA21-EMA55<330/1000;
F3:=EMA34-EMA13<130/1000 AND EMA34-EMA21<230/1000 AND EMA34-EMA55<330/1000;
F4:=EMA55-EMA13<130/1000 AND EMA55-EMA21<230/1000 AND EMA55-EMA34<330/1000;
F5:=EMA13-EMA21<100/1000 AND EMA13-EMA34<200/1000;
FF1:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA13,EMA21);
FF2:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA(C,13),EMA13);
FF3:=F5 AND C>EMA89 AND CROSS(EMA13,EMA21);
G1:=EMA21-EMA34<220/1000 AND EMA21-EMA34<320/1000 AND EMA21-EMA89<420/1000;
G2:=EMA34-EMA13<220/1000 AND EMA34-EMA21<320/1000 AND EMA34-EMA89<420/1000;
G3:=EMA55-EMA21<220/1000 AND EMA55-EMA34<320/1000 AND EMA55-EMA89<420/1000;
G4:=EMA89-EMA21<220/1000 AND EMA89-EMA34<320/1000 AND EMA89-EMA55<420/1000;
GG1:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA8,EMA13);
GG2:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA13,EMA21);
{DRAWICON(FF1 OR FF2 OR FF3 OR GG1 OR GG2,L-0.1,9);}
IF(FF1 OR FF2 OR FF3 OR GG1 OR GG2,1,0);

更多优质秘籍,请加主编个人微信ugouku探讨,同时欢迎分享转发。
微信打赏微信打赏

为众人抱薪者,不可使其冻毙于风雪!求各位看官打赏,打赏后加站长好友(微信caileap),共同探索

最后编辑于:2021/9/12作者:赵老哥小弟

头像

该用户很懒,还没有介绍自己。