通达信虚拟成交量指标

通达信虚拟成交量指标,还有很有用处的,有人不会预估当天成交量,不会比较,特此发出供研究使用。

(1)黄金柱

流通:CAPITAL/1000000,LINETHICK0;  
内外比:DYNAINFO(51),COLORYELLOW,NODRAW;  
五日量比:V/(REF(MA(V,5),1)/240*FROMOPEN),COLORYELLOW,NODRAW; 
换手:VOL/CAPITAL*100,POINTDOT COLORMAGENTA;
5换:SUM(100*V/CAPITAL,5),LINETHICK0;  
10换:SUM(100*V/CAPITAL,10),LINETHICK0;  
20换:SUM(100*V/CAPITAL,20),LINETHICK0;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,5),COLORWHITE;  
MAVOL2:MA(VOLUME,35)COLORYELLOW;  
MAVOL3:MA(VOLUME,135);
AA:=VOL>REF(V,1)*1.9;
AA1:=VOL
AA2:=VOL
STICKLINE(AA,0,V,1,0),COLORYELLOW;
STICKLINE(AA1,0,V,1,0),COLORGREEN;
STICKLINE(AA2,0,V,1,0),COLORMAGENTA;
TJ1:=COUNT(V>REF(V,1)*1.9,4)=1;
TJ2:=COUNT(VMIN(L,4) AND L>REF(L,1),3)=3 ;
TJ3:=TJ1 AND TJ2;
STICKLINE(TJ3,0,V,1,0),COLORRED;
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))*10;
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSEOPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE
HSL:=(XVL/20)/1.15;
攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(攻击,3);0,POINTDOT,COLORWHITE;
B1:SUM(LLJX,1),COLORCYAN;
B2:SUM(LLJX,2),COLORCYAN;
B3:SUM(LLJX,3),COLORCYAN;
B4:SUM(LLJX,4),COLORCYAN;
B5:SUM(LLJX,5),COLORCYAN;
B6:SUM(LLJX,6),COLORCYAN;
B7:SUM(LLJX,7),COLORCYAN;
B8:SUM(LLJX,8),COLORCYAN;
B9:SUM(LLJX,9),COLORCYAN;
B10:SUM(LLJX,10),COLORCYAN;
A1:IF(B1>REF(B1,1),B1,DRAWNULL),COLORMAGENTA;
A2:IF(B2>REF(B2,1),B2,DRAWNULL),COLORRED;
A3:IF(B3>REF(B3,1),B3,DRAWNULL),COLORRED;
A4:IF(B4>REF(B4,1),B4,DRAWNULL),COLORRED;
A5:IF(B5>REF(B5,1),B5,DRAWNULL),COLORRED;
A6:IF(B6>REF(B6,1),B6,DRAWNULL),COLORRED;
A7:IF(B7>REF(B7,1),B7,DRAWNULL),COLORRED;
A8:IF(B8>REF(B8,1),B8,DRAWNULL),COLORRED;
A9:IF(B9>REF(B9,1),B9,DRAWNULL),COLORRED;
A10:IF(B10>REF(B10,1),B10,DRAWNULL),COLORRED,LINETHICK3;
CC1:=IF(B1>REF(B1,1),1,0);
CC2:=IF(B2>REF(B2,1),1,0);
CC3:=IF(B3>REF(B3,1),1,0);
CC4:=IF(B4>REF(B4,1),1,0);
CC5:=IF(B5>REF(B5,1),1,0);
CC6:=IF(B6>REF(B6,1),1,0);
CC7:=IF(B7>REF(B7,1),1,0);
CC8:=IF(B8>REF(B8,1),1,0);
CC9:=IF(B9>REF(B9,1),1,0);
CC10:=IF(B10>REF(B10,1),1,0);
DD:=CC1+CC2+CC3+CC4+CC5+CC6+CC7+CC8+CC9+CC10;
VAX2:=EMA(C,7);
VAR3:=EMA(C,14);
VAR4:=EMA(C,25);
VAR5:=2*(VAX2-VAR4);
VAR6:=2*(VAX2-VAR3);
VAR7:2*(VAR6+VAR5);
DRAWICON(CROSS(VAR7,0),10000,13),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HX:=(HIGH - REF(HIGH,1));
LX:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HX > 0) AND (HX > LX)),HX,0),10);
DMM:=SUM(IF(((LX > 0) AND (LX > HX)),LX,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
ZZ:=(AV + NEWVOL);
DRAWICON(CROSS(ZZ,0),8000,9),COLORFF00FF;

--------------------------------------------------------------------------------

(2)饱和量虚拟

虚拟量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟量,0,3,-1),COLORFFFFFF;
【成交量】:VOL,VOLSTICK,COLORWHITE; VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE
主卖:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
【买卖差】:主买+主卖,NODRAW,COLOR0000FF;
STICKLINE(C>O,0,VOL,3,1),COLOR0000AA; STICKLINE(C
STICKLINE(【买卖差】>0,0,【买卖差】,1,0),COLOR0000FF;
STICKLINE(【买卖差】<0,0,-【买卖差】,1,0),COLOR00FF00;
DDX:=主买+主卖; DX:=MA(DDX,5)*10; DDX1:SMA(DX,3,1),COLORFF00FF;
DDX2:SMA(DDX1,3,1),COLORWHITE; DDX3:EMA(DDX2,5),COLORF0F000;
5日换:SUM(100*V/CAPITAL,5),NODRAW,COLOR00CC00;
PHD:=25; SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度%:IF(SAT>1,1,SAT)*100,NODRAW; 中点:=REFDATE(HHV(DDX1,100)/2,DATE);
STICKLINE(CURRBARSCOUNT=PHD,中点*1.9,中点*1.5,100,1),COLOR00DDDD;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=PHD,中点*1.88,中点*1.52,量能饱和度%,0),COLOR0033FF;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=PHD,中点*1.82,中点*1.58,量能饱和度%,0),COLOR0077FF;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=PHD,中点*1.76,中点*1.64,量能饱和度%,0),COLOR0099FF;
STICKLINE(CONST(C>O)=1 AND CURRBARSCOUNT=PHD,中点*1.7,中点*1.7,量能饱和度%,0),COLOR00DDFF;
STICKLINE(CONST(C
STICKLINE(CONST(C
STICKLINE(CONST(CBB00;
STICKLINE(CONST(C
DRAWTEXT(CURRBARSCOUNT=PHD+12,中点*1.35,'量能饱和度'),COLORWHITE;
---------------------------------------------------------------------------------------------------------------------

(3)划线虚拟量:

预测量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预测量,0,-1,-1),COLOR00C0C0;
实际成交:VOL,VOLSTICK;
上涨放量:STICKLINE(预测量/REF(VOL,1)>=1.5 AND C>REF(C,1),VOL,0,2.2,0),COLORYELLOW;
动态天量:IF(REF(预测量,1)=HHV(预测量,20),REF(预测量,1),REF(REF(预测量,1),BARSLAST(REF(预测量,1)=HHV(预测量,20)))),COLORFFCC66;
动态地量:IF(V=LLV(预测量,20),预测量,REF(预测量,BARSLAST(V=LLV(预测量,20)))),COLORYELLOW;
STICKLINE(预测量=动态地量 AND 动态地量
IF(预测量=动态地量 AND 动态地量

MAVOL5:MA(实际成交,5),COLORRED;
MAVOL8:MA(实际成交,8),COLORGREEN;
MAVOL21:MA(实际成交,21),COLOR808000;

-----------------------------------------------------------------------------

(4)接近原版模拟动能虚拟

{M1:1,100,5 M2:1,100,10}
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
盘虚万:VVOL/10000,NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL/10000,0,-1,-1),COLOR00C0C0;
VOLUME:=VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,M1);
MAVOL2:=MA(VOLUME,M2);
量万:VOL/10000,VOLSTICK;
A线万:MA(VOL,M1)/10000;
B线万:MA(VOL,M2)/10000;

流通亿:IF(C>=500,DRAWNULL,FINANCE(7)/100000000),NODRAW;
流通值:IF(C>=500,DRAWNULL,FINANCE(40)/10000/10000),NODRAW;
总市值:IF(C>=500,DRAWNULL,FINANCE(41)/10000/10000),COLORFFAA66,NODRAW;
资金贡献:AMOUNT/INDEXA*100,NODRAW;
上市日:IF(C<=500,FINANCE(42),DRAWNULL),COLORYELLOW,NODRAW;

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
ACD/">MACD :=2*(DIFF-DEA);
X1:=EMA(DIFF,5)*5;
X2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
X3:=IF(X2>0,X2,0),COLORRED;
STICKLINE(X2>0,0,X2,2,-1),COLORRED;
X4:=IF(X2<0,X2,0),COLORGREEN;
STICKLINE(X2<0,0,X2,2,-1),COLORGREEN;
资金动能A:=X2,LINETHICK1,COLORBROWN;
资金动能B:=X1,LINETHICK1,COLORBLUE;

选股:IF(CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25,1,0);
DRAWICON((CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25),资金动能B,1);
DRAWICON((CROSS(资金动能A,资金动能B) AND 资金动能B<-0.25),选股,11);

-----------------------------------------------------------------------------------------------------------------

(5)最简单虚拟

SJ:=IF(ISLASTBAR=1 AND DYNAINFO(8),ISLASTBAR*FROMOPEN,DRAWNULL);
预测成交:IF(ISLASTBAR=1,V*240/SJ,DRAWNULL),COLORGREEN,NODRAW;
STICKLINE(ISLASTBAR=1,V*240/SJ,DYNAINFO(8),3,2),COLORDDDDDD;
VOLUME:VOL,VOLSTICK; 

更多优质秘籍,请加主编个人微信ugouku探讨,同时欢迎分享转发。
微信打赏微信打赏

为众人抱薪者,不可使其冻毙于风雪!求各位看官打赏,打赏后加站长好友(微信caileap),共同探索

最后编辑于:2022/8/7作者:闽发论坛

头像

该用户很懒,还没有介绍自己。